Templates Plugins Courses

Problem with Bubble Page to PDF converter

In our demo page, there are few text elements with the multiple sentences inside and they are converted into PDF without an issue. Please check out their settings and compare with yours:


I presume our workable demo page as an example of settings. Would you kindly check and compare your settings with the plugin demo page?

Hope it helps :pray:
Regards,

Well it’s working on desktop, but when I’m downloading it from an iphone X on chrome (or safari), I get the same bug (screenshot) :confused:

@louislemercierpro, ok, got it.

I’ve succeeded to reproduce the issue you’ve faced on iPhone 11 too. Our team will investigate the root cause of this issue and fix it asap. It might take some time, thus I have to ask you for some patience. Once the issue will be resolved - I let you know.

Apologies for the inconvenience :pray:
Regards,

Thanks for your answer, good luck for the dev team!
Hope to hear good news from you soon as it’s a crucial part of my app :slight_smile:

Best regards,

1 Like

I have seen this issue consistently with Safari - previously reported but not been able to fix. On the same computer, Chrome has no problem. Hope this can be fixed!

1 Like

@louislemercierpro, @kenl, friends,

First of all, thank you for your patience :pray:

Second of all, we have made the update for the Page to PDF plugin with the fix, that resolves a few issues and the text bonding on iOS devices (Chrome/Safari) especially.

Would you kindly update your plugin to the latest version, check out the fixes, and notify me if the problems you were facing are resolved now?

NB! Please note, that if you are using the Page to PDF plugin on iOS (mob) devices, do not use line break (ENTER). We added a Note to the plugin, that for a large number of paragraphs you need to use BBCode.

Thank you in advance :slightly_smiling_face:
Regards,

Thanks for trying @louislemercierpro Unfortunately the issue persists. The current version available on Bubble is 1.26.0 - presume that is what you mean by the fix. Screenshot_10_06_2020__19_03

@kenl

Please make sure that you are not using line breaks (enter) within your text element, but you are separating your paragraphs with the BBCode.

:pray:
Regards,

When this happens, it’s either a repeating group or a concatenated block of text - where fields are strung together and line breaks are needed (like in an address text). Works fine on chrome and on windows machines.

Hello, @kenl. Apologies for such a delay in reply :pray:

I have tested your issue with the repeating groups and the only thing I can suggest you in this situation is to use the regular group element .

The repeating group content, after conversion, “expands” the whole content of the data table, used as a source of repeating group cell. And, as a result, creates a mess on the page and concatenates the text.

I have tried a few options on how to avoid such text concatenation with the repeating group content. If you need to display on the page only one specific row of the repeating group - it is better to use the regular group element for this case:

The converted content of this group won’t concatenate.
Please check the test page I’ve created and the video record:


https://www.loom.com/share/c4d451f97f694e6da45523e601bc6a9f

I hope this helps.
Regards,

Thanks for looking into it @kate. Unfortunately it does not appear to be that simple. First, it only happens on Safari. Second, it happens on both RG and G elements - we have both on the page and both get chewed up equally, but ONLY in Safari.

@kenl,

Understood, thank you. Can you please also add the error screenshots from the Safari console? Also, the video record of the reproducing your issue via Safari + console will be highly appreciated. This info will help us to investigate the issue you’ve described faster.

Regards,

Here it is

Safari

There is nothing to show on video - simply the PDF generated contains chewed up text - like this:

doc_pdf__1_page_

@kenl,

As I can see, the errors in the console are not caused by our plugin. Plus, we’ve tested on Safari the conversion of G and RG into the PDF file - there are no concatenated lines. We can not reproduce your issue, unfortunately, the plugin works well on our side.

Once more I need to ask you to make sure that you’ve added the [left][/left] tags to your text inside the G and RG
image

Here is the group element with the text:

And the repeating group with the text:

Please check carefully the settings of your app. You can also add our [email protected] email as a collaborator of your app, create the test page for us where we can view and test the issue (please grand the edit rights).

Regards,

That’s disappointing. Just now I noticed another error, perhaps related to Bubble’s recent changes to editor - now pages with multiple fields insert a line between the first line and the rest of the content. This happens on Safari and Chrome. This completely corrects with your plugin disabled. The [Left] tag does not cure this issue.

I have filed a bug report to Bubble, but the fact that others are seeing this error also means that there is an issue. We just have to find it. I can send you a video of this directly to you - shall I?

@kenl,

I’m not sure that your video record can help me to resolve a new issue you are facing within your app. Anyway, you can share it, sure.

As I have suggested, you can create a test page with the elements you are trying to convert, but with the text concatenation. Add our support account as a collaborator with the edit rights and I will check out what is the probable issue is causing your error.

Regards,

@kenl

Thank you for the video record you’ve shared with me.

Still, I have to ask you to wrap each line of the dynamic text you have into the [left] dynamic text [/left] tags. It should resolve the insert a line between the first line and the rest of the content issue and the text concatenation.

Take a look at this workaround:


image

One more tip, except the [left] tags, is the blank line under the first dynamic text line (but the drawback of this variant - the empty line above the first dynamic text line):

Please check and confirm :pray:
Regards,

I tried both solutions and unfortunately does not resolve the issue. Somehow the plugin throws off the Bubble page rendering. Removing the plugin does restore the page to normal. As far as I can see, it happens on Safari on MacOS and Chrome on both Windows and Mac.

The scrunching up of text reported in this thread is perhaps a similar error.

@kenl,

Will it be comfortable for you to add our [email protected] email as a collaborator of your app? With the edit rights, if you don’t mind. I presume, it can be useful to let us investigate the issues you’ve faced inside your app.

Thank you for understanding :pray:
Regards,

Ok I have changed every element on the page by inserting a blank space at the top and that has at least temporarily helped the formatting. If I have further trouble I will add you as a collaborator. Since the app is complex and critical, I did not want to do this first off - hope you understand. For now, please stand down.

1 Like