Templates Plugins Courses

Product Hunt Clone Template


#64

Looks like this is due to not having set the page to ‘Full Width’ during the setup - Argh! Would have been good to know that ahead of time.

If this isn’t set, the login isn’t displayed and the layout gets a little out of whack…

How can I go back and change this?


#65

Hey Toby,
sorry about that, we’ll ask Bubble to remove the assistant when an app is created based on template because it’s really obsolete - all those settings that are asked by the assistant are already configured. Sorry for the confusion. If changing the page to full width and recentering main groups and headers etc. doesn’t help then i would suggest to rebuild the app from template again and just close the assistant when it appears.
As for adding a referral parameter to all the links.
So if the link element has a static URL value, then you just apply it there. If it’s dynamic value, then you need to click right after the dynamic value, type the static value and click outside of the field - you’ll see the blue dynamic value and black/grey static value immediately after it. So that should be sufficient to implement your referral links.

Levon Terteryan
Founder @ Zeroqode & Bubblewits

let’s stay in touch on twitter!

zeroqode-for-web-160x120

Bubble Templates
Bubble Plugins
Bubble Courses
Convert Web to iOS & Android
No-code Development Services


#66

Thanks Levon.

  1. For the full width, yeah it was just a question of switching that on by default which I figured out was in the top part of the site. Not super easy to track down but ok.

  2. As for the /?ref: I wanted this to be dynamic somehow to make all exit links have the /?ref= added to it. I tried this using a new Collection called Sites which would then have a value urlRef = /?ref=blahblah. I’m trying to add that.

So right now I have the dynamic value being added and the ref being added manually, yet I was hoping to pull the text through from the Site collection so that I could save that as a parameter and only have to change that one value globally.


#67

Featured Collections
So I’ve been trying to get true featured collections on the main page - Effectively have done the following:

  1. Updated the collection schema is with a collectionFeatured = yes/no
  2. Updating a test collection with a true value so I know I have one to test.
  3. I edited the featured collection to do this: Changed the Repeatedgroup Collection to search Collections with this condition collectionFeatured = "yes"
  4. The result is no collection being returned… So I’m probably missing something but seems like an obvious thing…

Thoughts?


#68

in the url field of a link you can insert 2 dynamic expressions one after another, one would retrieve the link from the database, the other would get the ?ref parameter


#69

a very useful thing to use the debugger in the preview mode


#70

That’s what I’ve been trying to do… yet I cant’ seem to access just the Site's urlRef key.

I would have thought it would have just been adding that datapoint, yet I can’t see it. If I do a search for it I can’t just fetch that data like that. Struggling to see what I’m missing.


#71

Yeah the debugger’s not giving me anything other than saying:


#72

Which is pretty unclear…


#73

it’s difficult to help you out without seeing how exactly you configured things inside the app. But I believe the problem is with the “parent’s group” data. Are you sure that the parent group is not empty?


#74

hey @schuettemarkus, it’s still a side project for me, so unfortunately I wasn’t able to test the speed in a live environment, will report back once I do though!


#75

Yup the parent group’s data is present, because if I revert the condition, i get the desired result.

I wonder if it’s not worth having a slack group for this type of support so that others can follow too, its what VulcanJS does nicely.


#76

we followed https://forum.bubble.is example which worked great for all kind of support and discussions. And it also works as a knowledge base too. Don’t think it would be as efficient with Slack. We have a Slack group though but it’s more for general discussions - https://join.slack.com/t/zeroqode/shared_invite/enQtMzA5MTQ0OTk2MTE4LTZmMTVjYzdmNTlmMjA4NWVmYzBkNjBmNzEzYjZiN2Y1NzIwMmEzMTg2NzJlMzA0NmQ0YjgyMmUxNjJmOTM1YmU


#77

hey @levon,

I noticed an issue on dailyhunts.zeroqode.com.

When a topic is selected on the left hand menu, other product topics are shown in that group. For example, if “Tech” is selected, other topic categories will also show in the “Tech Topic State”

Any tips on how I can try to fix this?

Thanks!
randy


#78

Hey Randy,
i’ve made a qukck fix by adding an additional constraint in the repeating group as can be seen on the screenshot below (Product Topic contains …)
tested to work as expected


#79

hey levon thanks for the fast reply,

I copied the same constraint and it did not work, I also tried creating a fresh new app from scratch to see what was wrong,

Upon fresh installation, the product topic constraint was not in the repeating group, but the topic filters were working properly. So this change wasn’t updated in the new app I tested.

Was there another change that was made as well to get the topic filters working properly?

I haven’t changed any other settings in my app and kind of stumped here.

Thanks!
Randy


#80

Hey Randy,
if you check the element tree you will see that there are 2 different repeating groups.
one is visible by default, the other is visible when a topic is selected. The changes I made were to the second repeating group. I deliberately made the screenshot so that you can see which element I updated.
Levon


#81

thank you Levon, it is working now, however when you click the home topic button, it reverts to the last selected topic group (for example if tech is selected last, it stays on tech when it should show the whole home feed)


#82

it works fine for me at https://dailyhunts.zeroqode.com/


#83

Question: How can I bulk upload and set the creator? I have a number of products to import but I can’t import and update the Creator meaning that they don’t show up in the list of products, even if I activate them.

T