Templates Plugins Courses

☁️ AWS File Uploader - New Plugin from Zeroqode

has anyone successfully made a delete files workflow? The demo page deletes all files from the s3 objects. I don’t want to delete everything.

I have a state called files-to-delete that is a list of files I want to delete.

I tried deleting files-to-delete – didn’t work
I tried deleting files-to-delete’s URL - didn’t work
I tried deleting S3 Objects list of file URL’s: Filtered: files-to-delete contains this text - didn’t work.
I tried deleting S3 Objects list of file URL’s: Filtered: files-to-delete’s URL contains this text - didn’t work.
I tried deleting S3 Objects list of file URL’s: Filtered: files-to-delete contains this url - didn’t work.
I tried deleting S3 Objects list of file URL’s: Filtered: files-to-delete’ URL contains this url - didn’t work.

Hi @jeffmccutcheon,

Thanks for asking. Unfortunately, it is only possible to delete whether all files or a single file. This plugin comes with two actions: Delete files and Delete file. However, it is still possible to filter so you don’t delete everything from your bucket. You just have to set up the filter properly.

To showcase:

This way, you can delete with ‘Delete Files’ action, but having a filter constraint to delete only .jpg files.

Thanks!

1 Like

Does the delete file action work on backend workflows?

I can get it to work fine on the page, but I can’t get it to work as a backend workflow at all.

I’ve checked the logs and the workflow is definitely running, and I’ve checked that the correct URL for the file is being sent, but it wont delete the file when run as a backend workflow.

@alexander, I have updated the rating with 4 stars. But, I have one issue where I need help, Cropping on the basis of condition doesn’t seem to be working. I am attaching a video for your reference. Here I want cropping to be only done when image height is more than image width.

Hi @alan, unfortunately, it is not possible to accomplish this with our plugin because you actually obtain the image’s Height/Width after upload.

Hi @adam1,

I can see an existing thread here AWS delete file - Backend Workflow with your request. We’ll monitor this thread for further updates.

Thanks

Hello. It’s 9:10pm EST 7/21/2020 . I’ve lost access to all my AWS stored images in bubble. (Unable to view existing images or upload new. I can go to my s3 bucket and view images and no problem is reported.

is anyone else having issues?

EDIT: 9:58pm and all images are back up. Does anyone know what might have happened?

EDIT 10:47pm - half images show up, half don’t - can’t upload.

Hi @jeffmccutcheon,

Could you please confirm whether it relates to our plugin or not. Because Bubble itself is using AWS for storage, so perhaps it concerns the platform storage and not plugin related, unfortunately. It would be best to report it here https://bubble.io/bug_report in this case.

Please share a bit more details on issue (screenshots and/or screencast would be super helpful) so we can check on it and provide a better feedback asap.

Best,
Alex

You bet. I am using the zeroqode uploader. This problem is even stranger than I thought.

The problem only occurs on my laptop (in all browsers) and it is strangely intermittent.

LAPTOP
windows version 1903
OS 18362.959

DESKTOP (no issues)
Windows version 1909
OS 18363.959

I can be looking at a page full of photos uploaded from the zeroqode uploader weeks ago and if I hit f5 to refresh my browser, they all disappear. Not only in bubble, but in my database. The same thing happens if I use the zeroqode uploader on any page – all the pics disappear (not just the ones I was uploading, but all pics that are stored in s3 even the ones I uploaded days ago):

They do come back, but I haven’t figured out how I get them back. It seems to involve clicking back to the home page and navigating to the page the photos are on.

As I said, this doesn’t occur on my desktop. As a test, I uploaded a gallery on my desktop and then opened that page on my laptop. They were visible for about 1 second at which point they all disappeared.

Here’s a shot of my database unable to access them (they are the broken links under aaa images).

Is this possibly a security setting on my aws s3?

EDIT: Solved it - I unwittingly had my VPN on my on my laptop. This must mess with a security setting on my AWS S3.

Hi @jeffmccutcheon,

I’m glad you’ve managed to solve it. If you have any other questions, please let us know.

Thanks!

Upgrading to anything after (and including) 1.48 I have an issue:

Action “File uploader uploading is finished” runs after every individual file that is uploaded - so I no longer have an action that only runs after all files are uploaded.

Hi @jeffmccutcheon, thanks for reporting. Please let our development team investigate and fix plugin related bugs, then I’ll notify you on this matter asap!

Hi @jeffmccutcheon,

I’m reaching out with an update. Our team has managed to fix the plugin. Please upgrade to the latest version, refresh your app and give it a try again.

Also, make sure if you’re using the Multiple files option, your Image cropping and Image processing options are off:

image

image

Thanks for your patience.

@alexander, File (image) size is getting increased after it’s cropped, which ideally should never happen. I am adding a loom video for your reference, This issue is a little critical, as we have configured some checks on the file size of images getting uploaded and this bug is messing with those.

Hi @alan,

Thanks for reporting. I’m afraid it seems to be an issue on our side, but please let our team investigate and I’ll notify you back asap!

@alexander any update on this.

Hi @alan,

Thanks for catching up. We do have an update on work progress so far. Our dev team has managed to identify the reason of this issue and it has been already fixed. But some unexpected problem occurred with other plugin features, so we are fixing these as well and then we just publish a new version, so you’ll be able to run your app smoothly.

I’ll get back to you with another update asap.

Thanks for your patience. :pray:

1 Like

@alexander, another issue, when adding two “NoGUI Fileuploader” in a page, second one is triggering the first one when clicked. Attaching a loom video for your reference. In the video you can see, when Im clicking on “NoGUI Fileuploader B”, it trigges “NoGUI Fileuploader A”

Hi @alan,

We managed to fix all issues. Please upgrade the plugin to the latest version, refresh your app and give it a try again.

For this one, it is working as expected because the plugin was not designed to be used with more than one element on a single page, unfortunately. This may take time to re-create the logic of this plugin, but we collected your feedback and will work on future improvements if feasible.

Thanks for understanding. :pray:

1 Like